Hilfe nötig? Besuchen Sie unsere Support-Seite, dann


Teilweise fett schreiben in unsortierter Liste?

  1. Hallo,

    ich hoffe, ihr könnt mir helfen :-) Es geht um diesen Artikel: http://t.co/4DdOXEf Wie ihr sehen könnt, habe ich versucht, innerhalb einer Liste den Text teilweise fett und kursiv erscheinen zu lassen. Das klappt wunderbar, wenn ich ihn tippe - aber sobald ich auf "Vorschau" gehe oder ihn, wie jetzt, publiziere, wird nur der erste Punkt richtig dargestellt. Bei allen anderen fehlt "fett". Sobald ich in den "Bearbeiten"-Modus gehe, ist die Ansicht wieder korrekt. Ich habe schon alle HTML-Codes überprüft, es liegt meines Erachtens nicht daran. Alle Befehle sind vollständig. Habt ihr eine Idee, woran das liegen könnte?

    Vielen Dank für eure Hilfe!

    Marie

    Der Blog bei dem ich Hilfe benötige heißt roseately.wordpress.com.

  2. Hallo Marie,

    ich habe mal einen Blick in deinen Quelltext geworfen und denke ich sehe das Problem. Im ersten Absatz hast du den Text offenbar erst gefettet und danach kursiv gestellt, was zu folgender Verschachtelung führt.

    <em>
    <strong>
    Dein Text
    </strong>
    </em>

    Diese Kombination funktioniert. In den anderen Listenelementen hast du es offenbar genau anders herum gemacht. Erst kursiv gestellt, und dann gefettet, was logischerweise zu einer anderen Verschachtelung führt.

    <strong>
    <em>
    Dein Text
    </em>
    </strong>

    Das würde normalerweise funktionieren, wenn nicht ausgerechnet im CSS Code deines Themes für das "em" Element eine spezielle Formatierung notiert ist.

    em, i {
        font: italic 1.2em Baskerville,"Times New Roman",Times,serif;
        letter-spacing: 0.02em;
    }

    Für das strong Element gibt es keinen speziellen CSS Code. Ich vermute, das führt zu folgender Situation. Im ersten Fall (der funktioniert) macht der Browser die Schrift erst fett und weist dieser gefetten Schrift dann den CSS Code des em Element zu. Im zweiten Fall scheint der CSS Code des em Elements die Fettung des Textes irgendwie zu überschreiben und hält sich an die "font" Definition des CSS Codes.

    Ist wie gesagt nur eine Vermutung. Ich würde einfach probieren die Verschachtelung umzudrehen. Vielleicht könnte auch eine CSS Definition für das "strong" Element den Fehler ausbügeln. Dafür benötigst du allerdings das kostenpflichtige "Custom CSS" Upgrade.

    Gruß, Martin(IQ)

  3. Du Genie :-D Das war's tatsächlich. Hab es geändert und es klappt hervorragend, vielen Dank!

Thema geschlossen

Dieses Thema wurde für neue Antworten geschlossen.

Über dieses Thema

  • Alter des Themas: 3 Jahre • Gestartet von: 007tandborste
  • Dieses Thema hat 3 Beiträge
  • 3 posters
  • Aktuellste Antwort von 007tandborste
  • Dies Thema ist geschlossen
  • Dies Thema ist gelöst
  • RSS-Feed des Themas

Schlagwörter